Атака на сайты WordPress из-за версии PHP

0
Обновление версии PHP - безопасность сайта.
- Реклама -

Версии PHP 5.6 и 7.0, которые используют 57,1% всех сайтов WordPress, перестанут обновляться в декабре 2018 года.

Чем это грозит?

Такие сайты станут небезопасными.

А как следствие — потеря трафика и ранжирования в поисковиках.

На графике ниже видно, сколько сайтов работают на PHP 5.6 и 7.0. То есть больше ⅓ используют версию 5.6.

Версии PHP на сайтах WordPress
Что такое версии PHP?

PHP — это язык программирования для создания сайта. А версии отличаются наличием доработок и улучшений. С появлением каждой новой версии обновляется и WordPress.

Когда прекращается поддержка обновлений безопасности?

Для версии PHP 5.6 — 31 декабря 2018 года.
Для PHP 7.0 — 3 декабря 2018 года.

Прекращение поддержки версии PHP на сайтах WordPress

Почему так происходит?

Поддержка безопасности осуществляется в течение нескольких лет, пока не выйдет срок службы, то есть End of Life (EOL).

Вот что пишут о EOL на официальном сайте PHP:

«Это версия, которая больше не поддерживается. Пользователи должны как можно быстрее обновиться, так как их сайты могут подвергнуться атакам и взлому».

Что будет, если вы не успеете обновить версию PHP?

Многие плагины, темы и сам WordPress перестанут работать с этими версиями PHP.

Как определить вашу версию PHP?

Самый простой способ — войти в панель управления хостингом и найти ссылку на раздел о PHP.

Вы также можете использовать плагин WordPress phpinfo. Установите его, он расскажет, на какой версии работает ваш сайт. Потом можете его удалить.

Или обратитесь в техподдержку хостинг-провайдера, чтобы вам помогли определить версию PHP и дали инструкции для обновления.

Как обновить PHP от 5.6 7.0 до свежей версии?

Шаг №1. Сделать резервную копию сайта.

Это важно. А самый простой способ сделать копию — использовать плагин UpDraftPlus. Он бесплатный.

Шаг №2. Проверить обновления и совместимость плагинов.

Убедитесь, что все плагины на сайте обновлены до последней версии. Если плагин не обновлялся более года, проверьте, чтобы он был совместим с последней версией PHP (7.2).

Если нет, удалите его и подключите аналогичный совместимый.

Неподдерживаемый долгое время плагин может представлять угрозу безопасности вашего сайта.

Шаг №3. Обновить версию PHP.

В панели управления хостинга перейдите в раздел PHP и обновите до последней версии.

Безопасность сайта

Безопасность — не главный вопрос SEO. SEO — это все о ранжировании.

Но если ваш сайт будет взломан, а поисковый трафик исчезнет… в общем, какие там оптимизация и продвижение.

Источник: SEJ

- Реклама -

ВАШ КОММЕНТАРИЙ

Оставьте комментарий!
Ваше имя